www.3859.net > 版本5.6.5的php连接mysql问题

版本5.6.5的php连接mysql问题

5.6不能用mysql_connect了 看看手册 从5.5开始已经被弃用了

连接方式多种多样 一般来说php5,我用mysqli来连接$db = new mysqli("localhost","用户名","密码","库名"); 用法$rs = $db->query(""); while ($record = $rs->fetch_assoc()) { echo $record['字段名']; } 别的方法连接也可以,推荐用上面的,一般会写一个 class db extends mysqli 这样可以封装一些自己的操作 求采纳为满意回答.

$link = mysql_connect("mysql_host", "mysql_user", "mysql_password") 这一句我不知道你是怎么写的,也不知道你是从哪里学的,我推荐你一个网站,去哪里好好学学.另外,你应该买一本好点的入门书籍.www.phpchina.cn

php 5.5以后对mysql的操作推荐pdo的方式了,否则会警告的,mysqli 的话呢,php 版本不是低的离谱应该是没有问题的

应该是Mysql 有问题 你用 root 账户登录呢

解决办法:如果安装的PHP5以上的版本,请在PHP的配置文件php.ini中去掉;extension=php_mysql.dll前面的;符号.另外复制PHP目录下的libmysql.dll到系统目录下,例如:C:/WINDOWS/system32重新启动APACHE,就可以了.最好是在配置完apache+php+mysql后写一个?> 文件来看PHP的配置,其中就能看到是否支持连接MYSQL.

你用的是wamp , apache+php+mysql.这个是你的php程序判断连接不上数据库, 远程的数据库有开启让外边连接的权限吗? 很多远程mysql服务器就算设置了远程, 都是授权给指定的服务器ip的.应该是无权连接, 所以提示你conn.php出错.

1,首先确保你的mysql已经正常运行并且可用,在cmd里用mysql client测试一下2,确保设立的正确的mysql用户帐户,以及root用户是否设立了口令,必要时使用grant语句设定用户权限,3,确认后重新运行脚本 :)

首先需要下载安装 php5-mysql这个模块.Ctrl+Alt+T,直接打开终端.输入 sudo apt-get install php5-mysql ,然后输入当前用户的密码后,开始下载并安装该模块.安装完毕后,需要重启一下Apache服务.在终端输入 sudo /etc/init.d/apache2

这个是数据库密码问题.希望我的回答可以帮到你,有什么不懂可以追问.

友情链接:ceqiong.net | qwfc.net | clwn.net | snrg.net | acpcw.com | 网站地图

All rights reserved Powered by www.3859.net

copyright ©right 2010-2021。
www.3859.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com